Two versions of Process Blocker are available below. Which one you need to download depends on your operating system. Note that only Windows XP and later are supported.

As Windows Installer packages are used for distributing Process Blocker, you have to have Windows Installer 3.0 or later on your computer. Everybody usually has it, but a required version can always be found here if necessary.

Version Info

Current version: 1.0.8

Release Date: 10/03/2014

x86 – Download

x64 – Download